coWiki 0.3.4
Current user:   guest   Change Preferences
   List directory   Similar   Print version 
Diff: Install
 Legend:   Removed   Changed   Added 
 Ownership:  rw-rw-r-- iezzip users
 Modified:  26 Apr 04, 12:08
 Modified by:  Philip Iezzi (iezzip)
Rev.:  2 (Old)
 
 Ownership:  rw-rw-r-- iezzip users
 Modified:  05 May 06, 13:14
 Modified by:  Philip Iezzi (iezzip)
Rev.:  9 (Current)


+ Pigalle %TITLE%

+ Pigalle %TITLE%


<toc>

---

++ Requirements

* Any kind of operating system. Pigalle has been tested on both Linux and Windows.
* Apache webserver <noop>(</noop>((http://www.apache.org))<noop>)</noop>. Pigalle works on both Apache 1.3.xx or 2.0.x. On Windows, it might work on IIS as well, but currently we are not doing any testing on it.
* One of the following database systems:
++ Requirements

* Any kind of operating system. Pigalle has been tested on both Linux and Windows.
* Apache webserver <noop>(</noop>((http://www.apache.org))<noop>)</noop>. Pigalle works on both Apache 1.3.xx or 2.0.x. On Windows, it might work on IIS as well, but currently we are not doing any testing on it.
* One of the following database systems:
* *MySQL* 4.0.x database or later version <noop>(</noop>((http://www.mysql.com))<noop>)</noop>.
* *MySQL* 4.0.x/4.1.x database or later version <noop>(</noop>((http://www.mysql.com))<noop>)</noop>.
* *PostgreSQL* <noop>(</noop>((http://www.postgresql.org))<noop>)</noop>
* *PostgreSQL* <noop>(</noop>((http://www.postgresql.org))<noop>)</noop>
* *SQLite* <noop>(</noop>((http://www.sqlite.com))<noop>)</noop>
* *SQLite* <noop>(</noop>((http://www.sqlite.org))<noop>)</noop>
* *Microsoft SQL Server 2000* <noop>(</noop>((http://www.microsoft.com/sql/))<noop>)</noop>
* The following database systems might be supported in the near future: *FrontBase*, *Borland InterBase*, *Sybase*
* *Microsoft SQL Server 2000* <noop>(</noop>((http://www.microsoft.com/sql/))<noop>)</noop>
* The following database systems might be supported in the near future: *FrontBase*, *Borland InterBase*, *Sybase*
* *PHP 5 or later version*. PHP 4.3.x won't work! Currently Pigalle runs fine under PHP 5.0.0RC2. We do not support any lower versions.
*
/Warning: ZendEngine2 (PHP 5) itself is under development too and might cause strange side effects, errors or segmentation faults./

* *PHP 5.1 or later version*.
*
Image Library:
* *ImageMagick* (recommended!)
* PECL/imagick ImageMagick wrapper
* GD library
* NetPBM
* of course all of it working together ... and a HTML-browser

For your information: the ((http://pigalle.phpee.com/)(Pigalle demonstration)) we are using currently is actually served by a PHP %PHP_VERSION% and ZendEngine %ZEND_VERSION% backend.
* of course all of it working together ... and a HTML-browser

For your information: the ((http://pigalle.phpee.com/)(Pigalle demonstration)) we are using currently is actually served by a PHP %PHP_VERSION% and ZendEngine %ZEND_VERSION% backend.

---

++ Quick Install

<q>
Installation of Pigalle is EASY! There is not even an installation script required to run, because Pigalle automatically detects a new installation. The current installation instructions are located in your Pigalle distribution: /<noop>/private/doc/</noop>*INSTALL*/.

<code>
[1] Unzip the distribution and make sure you keep the file-structure

[2] Edit config.inc.php and enter your database information
At least, change the following settings:

$conf['dsn'] = array(
'username' => 'xxxxxxxx',
'password' => 'xxxxxxxx',
'database' => 'xxxxxxxx'
);

[3] Make the following directories writable:

chmod 777 cache/
chmod 777 albums/
chmod 777 archives/
chmod 777 private/log/

If your webserver runs under the same group as your user, chmod 660
might as well do it.

[4] Run Pigalle!
That's it, you won't need any further install instructions, as
Pigalle does automatically detect a new installation and creates
the needed tables in your database. Default configuration is good
in most cases.

Run index.php from your browser and enjoy Pigalle!

[5] To create a new album, just copy a whole directory that contains all
your images into /albums. Next time you call index.php from your
browser, the new album will be automatically available.

[6] To configure your new installation, please log-in with the default
admin user:

username= admin
password= 1234

You should then enter the "User Administration" (link on top of page).
Either create your own user(s) and delete the default admin user or
at least change his password.
</code>
</q>

---

++ Upgrading to a newer version

<q>
Upgrading to a newer version of Pigalle is easy. All you need to do is to replace the whole Pigalle directory with the newer release files. You only need to re-enter the connection options of your database connection in the new =config.inc.php=. There is no further action required. Pigalle will automatically upgrade your database scheme if required on the first web access to your Pigalle installation. It will detect your previous version information and automatically runs an incremental upgrade.
</q>


Home | Pigalle | YaBook | PPhlogger | Sourdough | RSS 1.0 | GEO URL

Driven by coWiki 0.3.4 (Boron) web collaboration tool.